Shortly after saving edits to a Mediasite presentation in the Mediasite Video Editor, the Video Save Jobs status in the top-right corner of the editor indicates the save has failed.
Cause
This issue often occurs when the save is attempted before the original presentation has been completely processed.
Two stages of processing will occur when you upload a video file to Mediasite. First, Mediasite will process the uploaded video into a Mediasite presentation, at which point the video is capable of playback. You will receive an email after this process is complete:
Video 1
MP4: Completed
Generated Slides: Completed
After the first stage of processing completes, the second stage of multi-bitrate processing will begin. The video is encoded at varying qualities so that viewers can be delivered an appropriate quality based on their internet capabilities. This is known as Smooth Streaming. You will receive an additional email after this process is complete:
Video 1
MP4: Completed
Smooth Streaming: Completed
Generated Slides: Completed
If you attempt to save an edit to the video before the multi-bitrate stage of processing is complete, the save will fail.
Solution
Wait to save edits to your video until after you receive the second email telling you the Smooth Streaming processing is complete. The time required to process a video into a Mediasite presentation completely depends on the source video's length, quality, and complexity of the video image.
Additional Information
The developer of Mediasite has acknowledged this behavior as a known issue and plans to address it in a future release of Mediasite.